Local Disaster Planning, Mitigation, Response, and Recovery
Urban Tree Risk Index (UTRI)
v 1.09a

December 13, 2012

1

Model Objective:

2
4

The objective of the Urban Tree Risk Index model (UTRI) is to prioritize street segments of a community for more
detailed (comprehensive or intense) risk assessment, mitigation, and management. In addition, the UTRI and
resulting urban tree risk management is a critical component in the Vegetation Risk Management Plan.
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Model Overview:

6

CARPDC has developed a relatively simple GIS approach to rank areas of the community for their likely risk to
infrastructure and human life in the event of a natural disaster (e.g. hurricanes, ice storms, straight-line winds)
1
based on the publication Urban Tree Risk Management: A Community Guide to Program Design .
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The Urban Tree Risk Management guide outlines a process for prioritizing, assessing, and mitigating tree risk in
urban areas. Its principal underlying concept is the “tree risk zone” that guides urban forest managers to those
areas of greatest concern when resources are limited. The CARPDC Urban Tree Risk Index (UTRI) tool is used to
identify and prioritize street segments as “tree risk zones” that provide the prioritization framework for planning,
assessment, mitigation, and response to natural disasters. The UTRI is the basic driver for the Vegetative Risk
Management Plan which includes collaborative strategies, the tree risk map, street segment (tree risk zone) field
verification forms to guide detailed assessment, pre- and post-disaster mitigation, debris estimation, and disaster
response.
The methodology (GIS model) and resulting ranking is a “springboard” for state, regional and local collaboration of
community leaders, emergency managers, regional and local planners, community staff, and the urban forestry
profession.
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The UTRI model supports the “Collection Strategy” prioritization outlined in the Public Assistance Debris
Management Guide (FEMA 325, July 2007).
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In addition, UTRI supports key concepts of the National Disaster Recovery Framework :
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local government has the primary role of planning and managing all aspects of the community’s recovery,
the ability of a community to accelerate the recovery process “beginning” with its efforts in pre-disaster
preparedness, mitigation and recovery capacity building,
an impacted community assumes the leadership in developing recovery priorities and activities that are
realistic, well-planned and clearly communicated.
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GIS Approach:

29

As developed within GIS the Urban Tree Risk Index (UTRI) becomes a powerful tool at the state and regional level
for long-term disaster planning, and at the regional and local levels for planning, mitigation, response, and
recovery.
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Tree risk is associated with: targets (infrastructure or human), trees and their structural characteristics, and an
evaluation of failure probability. UTRI does not look at individual trees, but at the spatial distribution of high
priority but vulnerable community infrastructure, human population, and tree distribution (based on tree canopy)
to guide planning, prioritized assessment, and mitigation by urban forest and emergency managers.
UTRI uses a street segment as the smallest risk zone element for analysis. A street segment is the portion of a
street between two intersections, or from an intersection to the end of that street. Within any area being
analyzed, the street segment length may vary considerably. However, these street segments are typically shorter
and more uniform (i.e. less variability) in urbanized areas where disaster effects are greatest for people and
infrastructure (i.e. street network density is typically related to non-street infrastructure which is related to

1

Jill D. Pokorny (Coordinating Author), USDA Forest Service, Northeastern Area, State and Private Forestry, 1992 Folwell Ave, St. Paul, MN
55108, NA-TP-03-03, 2003, 194 pages.
2
National Disaster Recovery Framework: Strengthening Disaster Recovery for the Nation, Department of Homeland Security (DHS), Federal
Emergency Management Agency (FEMA), Washington DC, September 2011, 116 pages.
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population density during the daytime and/or nighttime; the assumption here is that as the built environment
intensifies, then there are probably more people).
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The UTRI implementation of “tree risk zones” helps:
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1.

develop Debris Management Plans and Hazard Mitigation Plans

45

2.

identify areas for block-level or individual tree risk assessment
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3.

guide local risk management and pre-storm mitigation (pruning and removal)
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4.

create non-threatening tree planting projects (proper species and site evaluation)
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5.

stratify a debris estimation sample

49

6.

prioritize disaster response
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GIS Data: Sources:
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The most accurate and current GIS data should be obtained. Possible sources include:
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Municipal planning and GIS agencies
Municipal urban forest management
County EM and planning agencies
Regional planning agencies
State agencies (EM, DOT)
Department of Homeland Security
US Census
USDA Farm Service Agency (FSA)
US DOI, Geological Survey

Examples: facilities, boundaries
Examples: tree canopy, tree risk management
Examples: facilities, imagery
Examples: transportation, imagery
Examples: transportation, facilities
Examples: HSIP Gold including facilities, population
Examples: population, other TIGER lines
Examples: NAIP 1 meter imagery
Examples: MRLC 30 meter tree canopy

61

GIS Data: Assembly:

62

For the area of interest (AOI), the GIS data needed to develop the tree risk rating and calculate the priority index
that supports the Vegetation Risk Management Plan includes the following spatial layers:
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1.

county and municipal boundaries

65

2.

street and highway infrastructure

66

3.

community infrastructure most important during disaster response (e.g. hospitals, EM, police, fire, water
supply, and water treatment)

68

4.

population density

69

5.

tree canopy
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Within the GIS methodology developed, each of these UTRI components is converted to a GIS raster layer(s) with a
rating that reflects component importance or level of concern. The resolution of the rating can vary depending on
the availability of GIS data. In the Autauga and Elmore County (Alabama) prototypes, 30 meter pixels were used.
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The UTRI represents the important relationships that exist among these GIS layers relative to disaster planning,
response, and recovery (short-term and long-term).
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For example, storm damaged trees can:
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directly injure or damage…
 people
 facilities (e.g. buildings, bridges)
block emergency access to…
 injured people
 emergency facilities (e.g. EM, public safety, hospitals, shelters)
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disrupt…
 communication
 energy
 water supply and treatment
 food supply
affect…
 debris generation (i.e. quantity)
 debris handling (i.e. number and locations of debris sites)
 the “flow” of environmental services from tree canopy (i.e. temporary or permanent
losses/reductions in stormwater, shade (energy), PM10 capture, and visual or noise buffers)
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GIS Data: Preparation:

93
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Assignment of priority ratings within each layer are dependent on the layers attribute properties and the
regional/local disaster perspective. The scale of the UTRI analysis (that is, the area of interest) has a bearing on
assignment of individual layer ratings that are “summed” into the final UTRI risk index. For example, if developing
a UTRI for a municipality, regional health care and the transportation corridors to reach those regional care
facilities may not be as important if the community has local facilities (i.e. emergency care options) of sufficient
size and capability for the planned event.
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GIS Data Overlay Relationships:
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Street Risk
People Risk
Facilities Risk
Tree Risk

UTRI
(by street segment)
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Objective: Users will step through the model, format input data layers from multiple sources, and create five raster layers that can be summed to create the UTRI. The final UTRI is then assigned back to the street segment layer for field verification, urban forest risk management, disaster
planning, debris stratification, and/or response prioritization.
UTRI GIS Model Worksheet & Tool Description
Folder: __________________________________________
Geodatabase: ____________________________________

Project Name: ____________________________________
Process Step

1

Assemble data layers needed
(see Data Source column for
steps -).

3

Data Source

GIS /Model Processing

See below in this
column and Notes
column links.

NA

4

Model Tools

Data Layer(s)

NA

NA

5

Coordinate System: ___________________________________________

Input Attribute

Output Attribute

Assignment or Reclass

Model Notes

GIS Processing Notes (As Built)

NA

NA

NA

http://www.census.gov
http://www.mrlc.gov
https://www.hifldwg.org
Other local/regional/state sources

Input Layers:

Create a folder & subfolders
for the project; for example:

…\UTRI2012Elmore
…\UTRI2012Elmore\So
urceData
…\UTRI2012Elmore\M
aps
…\UTRI2012Elmore\Do
cuments).

2

3

4

4a

Create an ArcMap
personal/file geodatabase
and map document (i.e.
project) in the project “root”
folder from the previous
step.
Set the default geodatabase.

Create project boundary; i.e.
the area of interest (AOI)

Process streets (Targets)

Process facilities (Targets)

Resolution: _____ meters

Output Layers:

Other Comments:

NA

ArcCatalog
 Create/select folder
File=>New Personal Geodatabase
ProjectNameDate
ArcMap
File New…
Dialog=>Default geodatabase

NA

Data Download
 Census data or other
UTRI Model
 Select feature (AOI)
 Extract AOI feature
 Buffer to 1k or desired distance
 Project to project coordinates
ArcMap
TB=>Select Feature (e.g. County)
RC=>Data=>Export Data
ArcToolbox
Analysis Tools=>Proximity=>Buffer

02_UTRI-AOI

2010 Census
TIGER Lines Features => All
Lines (i.e.
“edges”)
or…
Features => Roads
=>All

Data Download
 Census data or other
UTRI Model
 Add UTRI_T (set to 0)
 Clip with AOI
 Project to project coordinates
 Classify
 Buffer to right-of-way (ROW) extent
ArcToolbox
 Convert to raster at project
resolution
ATB=>Conversion Tools=>To
Raster=>Feature to Raster

03_UTRI-Street
03_UTRI-Blocks

Local or
HSIP Gold

Data Download
 Data as available
UTRI Model
 Add UTRI_F (set to zero)
 Clip with AOI
 Project to project coordinates
 Classify
 Buffer facility vicinity
ArcToolbox
 Convert to raster at project
resolution

04_UTRI-Facility

2010 Census
TIGER Lines Geographic
Areas=>Counties
(and equivalent)

NA

AOI_Region
AOI_County
AOI_City
AOI_Other

AOI_Street
vStreet
rStreet

AOI_Facility
vFacility
rFacility

NA

NA

MTFCC

Name or
description

NA

NA

UTRI_S to raster
cell

UTRI_F to raster
cell

The geodatabase is an excellent file/layer organizational tool
and may also function as process documentation. It should
hold all intermediate layers used in the processing as well as
the final vector and raster layers.
An example ProjectNameDate might be:
UTRI2012Elmore.mdb
The original supporting data (e.g. NLCD or Census) does not
have to be placed into the geodatabase.
Set projection and datum for the geodatabase and then make
it the ‘default’ geodatabase when you create your map
document (i.e. the mxd; the ‘project’).
Note: Users may opt to use ArcGIS shapefiles and stand-alone
raster files if desired. Layer name may be used as the
shapefile and raster file names.

Input Layers:

Source: http://www.census.gov/cgibin/geo/shapefiles2010/main.
Use UTRI model tool or ArcToolbox.
This step may include multiple levels (e.g. county,
municipality, neighborhood).
Intermediate layer names should lead to or reflect the final
layer to be used by UTRI; e.g.
AOI_CountyCensus (i.e. first data export layer)
AOI_County (i.e. after projection and datum set)
AOI_County1k (e.g. 1 kilometer buffer)

Input Layers:

UTRI_S & Cell:
S1100 = 4
S1200 = 3
S1300/S1400 = 2
Others important to
your community = 1
All else = 0

Source: http://www.census.gov/cgibin/geo/shapefiles2010/main.
UTRI_S is an integer value. (STREET)
Use 50’ buffer from centerline or appropriate width based on
street type for the segment or other local knowledge to create
the polygon vector layer of street segments.
Trees within the street buffer represent the area of concern
for disaster planning if they can adversely affect people,
facilities, or transportation.

Input Layers:

UTRI_F & Cell:
Hospitals=5
Fire, Police, Emergency
Management Center =
4
Communication
Towers, Water
Treatment Plants,
Water Towers, Waste
Water Treatment Plants
=3
Schools, Parks, and

Source: Local or HSIP CD.
UTRI_F is an integer value. (FACILITY)
Buffer the facilities with a 100 meter or 200 meter radius.
This represents the “immediate area” of risk for each critical
facility.

Input Layers:

NA

NA

Output Layers:

Other Comments:

Output Layers:

Other Comments:

Output Layers:

Other Comments:

Output Layers:

Other Comments:

3

ArcGIS is ArcCatalog, ArcMap, ArcToolbox, and ArcGIS Extensions; TB refers to ArcMap menu tools & toolbars; ATB refers to the ArcToolbox, TOC is the ArcMap table of contents, RC is ‘right-mouse click’; Dialog is the input dialog window from a menu selection (e.g. New…).
“=>” Indicates ArcGIS menu selections.
5
Suggested layer names; AOI is area of interest and used for clipping. Some steps will have multiple layers; use v prefix for vector and r prefix for raster in those cases (e.g. vStreet and rStreet represent the same data).
4
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Objective: Users will step through the model, format input data layers from multiple sources, and create five raster layers that can be summed to create the UTRI. The final UTRI is then assigned back to the street segment layer for field verification, urban forest risk management, disaster
planning, debris stratification, and/or response prioritization.
UTRI GIS Model Worksheet & Tool Description
Folder: __________________________________________
Geodatabase: ____________________________________

Project Name: ____________________________________
Process Step

Data Source

3

GIS /Model Processing

4

Model Tools

Data Layer(s)

5

Input Attribute

Output Attribute

ATB=>Conversion Tools=>To
Raster=>Feature to Raster

Process facilities
(for Step 4b that follows)

4b

5

6

6a

Process streets (Access to
Facilities)

Process population (Targets)

Process tree canopy
(Potential Tree Failure)

Area of Interest Mask

vFacilityZone

UTRI_F

Coordinate System: ___________________________________________
Assignment or Reclass
other locations where
people congregate = 2
Others important to
your community = 1
All else = 0

Data Download
 Data as available
UTRI Model
 NA
ArcToolbox
ATB=>Analysis
Tools=>Proximity=>Buffer
2010 Census
TIGER Lines Features => Roads
=>
Primary/Secondar
y
vFacilityZone

2010 Census or
HSIP LANDSCAN

NLCD (USGS)
NAIP (FSA)

vStreet

Data Download
 Data as available
UTRI Model
 Add UTRI_C (set to zero)
ArcMap Tools
 Cumulative UTRI_F into UTRI_C
RC=>[TOC Layer] Open Attribute Table
TB=>Selection=>Select by attribute
TB=>Selection=>Select by location
RC=>[Attribute Name] Field Calculator
ArcToolbox
 Convert to raster at project
resolution
ATB=>Conversion Tools=>To
Raster=>Feature to Raster

NA

Data Download
 Census data or other
UTRI Model
 Extract population in AOI
 Convert to vector (polygon)
 Project to project coordinates
 Calculate square miles (=acres/640;
=square feet/27878400; =square
meters/2589988)
 Calculate population/square mile
 Reclassify
ArcToolbox
 Convert to raster at project
resolution
ATB=>Conversion Tools=>To
Raster=>Feature to Raster

05_UTRI-Census

Data Download
 Most current NLCD tree canopy
 Or, local tree canopy
 Or, classify most recent NAIP
UTRI Model (NLCD)
 Clip to buffered AOI
 Reclassify (raster operation)
 Project to project coordinates
ArcToolbox
ATB=>Data Management
Tools=>Raster=>Raster
Processing=>Clip
ATB=>Data Management
Tools=>Projections and
ATB=>Transformations=>Raster=>Proj
ect Raster
ATB=>Spatial Analyst
Tools=>Reclass=>Reclassify

06_UTRI-Canopy

Data Download
 Streets from Step 

vCFstreet
rCFstreet

UTRI_F

vCensus
rCensus

AOI_Canopy
rCanopy

vAOImask
rAOImask

UTRI_A to raster
cell

SqMiles
Pop_SqMile
UTRI_P to raster
cell

Cell Value

Select any
integer attribute
with a value of 1

Cell value (UTRI_T)

Cell

Model Notes

GIS Processing Notes (As Built)

UTRI_F is an integer value as assigned in vFacility.
Selected critical facilities (e.g. use two highest UTRI_F levels)
should be buffered to a distance of 3000 meters to 5000
meters and used in the next step that identifies critical routes
for these facilities in the AOI.

UTRI_A is an integer value. (ACCESS)
This will be the GIS layer of primary roads in the AOI; assigned
the risk ratings for all facilities that depend on that particular
street or street segment; segment risk is cumulative for all
critical facilities (CF) in vFacilityZone.
When making calculations for street segment rating for facility
access:
work alternatively in two layers: vFacilityZones, vCF_Streets
set all UTRI_C to one (1) in v_CF_Streets
use a “Select by Attributes…” for UTRI_F > x (rating desired)
calculate UTRI_C = UTRI_C + x

Input Layers:

Classification- Try
Quantile, Natural Breaks
(Jenks) or other symbol
classification technique
with four or five classes.
UTRI_P & Cell:
Class 5 = 4
Class 4 = 3
Class 3 = 2
Class 2 = 1
Class 1 = 0

Source: http://www.census.gov/cgibin/geo/shapefiles2010/main.
Source: Local or HSIP CD.
UTRI_P is an integer value. (POPULATION)
When making calculations for population density:
set all Pop_SqMile to zero (0)
use a “Select by Attributes…” for areas > 0 (square miles)
calculate Pop_SqMile = Population/SqMiles
Areas with zero population / square mile should be set to
UTRI_P = 0.

Input Layers:

Classification- Try
Quantile, Natural Breaks
(Jenks) or other symbol
classification technique
to create from five or
eleven classes.
Cell (UTRI_T):
91-100 = 10
81-90 = 9
71-80 = 8
61-70 = 7
51-60 = 6
41-50 = 5
31-40 = 4
21-30 = 3
11-20 = 2
1-10 = 1
0=0

Tree canopy is available from the MRLC:
http://www.mrlc.gov/index.php
The National Land Cover Database (NLCD 2001) tree canopy
layer is downloaded as a raster and the cell value represents
percent of tree canopy (from 0 to 100%) for the 30 meter
pixel.
This is a single file for the entire coterminous US and is in the
Albers projection and in meters, WGS84.
The MRLC Consortium Viewer at:
http://gisdata.usgs.gov/website/mrlc/viewer.htm
can be used to download an area that includes a single or
multiple counties (not by county boundary but by rectangular
selection area that you estimate will include your AOI). This
raster file can then be clipped with the AOI.
When downloading from the viewerthe default is to get the
landcover dataset. To specify tree canopy, click on the
download tab (in the right panel), and uncheck landcover and
select tree (forest) canopy).
Then make your download area with the selection box tool (in
the left panel near the bottom).
ArcGIS Spatial Analyst Extension is required for most of the
operations in this and the following steps.

Input Layers:

Assign value of 1 to the
areas within the AOI that
should have a risk index

Use approximately 3x the distance used in Step 3; 150’ buffer
from centerline or appropriate width based on street type for
the segment or other local knowledge to create the polygon

Input Layers:

Cumulative UTRI_A from
the critical facility zones
layer.

Resolution: _____ meters

GIS Data Preparation and Processing
CARPDC, Montgomery, Alabama

Output Layers:

Other Comments:

Output Layers:

Other Comments:

Output Layers:

Other Comments:
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Objective: Users will step through the model, format input data layers from multiple sources, and create five raster layers that can be summed to create the UTRI. The final UTRI is then assigned back to the street segment layer for field verification, urban forest risk management, disaster
planning, debris stratification, and/or response prioritization.
UTRI GIS Model Worksheet & Tool Description
Folder: __________________________________________
Geodatabase: ____________________________________

Project Name: ____________________________________
Process Step

Data Source

3

GIS /Model Processing

4

Model Tools

Data Layer(s)

UTRI Model
 Buffer to a distance that exceeds
right-of-way (ROW) extent
ArcToolbox
 Convert to raster at project
resolution
ATB=>Conversion Tools=>To
Raster=>Feature to Raster

7

8

9

10

Create UTRI (Raster)

Create UTRI (Vector)

Create field verification
report

Produce a stratified random
sample (street segments) for
debris estimation in i-Tree
Eco or i-Tree Streets.
Produce UTRI street segment
map.

rStreet
rFacility
rCFstreet
rCensus
rCanopy
rAOImask

rUTRI

NA

NA

Input Attribute

Output Attribute

(or due field
calculator to set
it)

Assignment or Reclass

Model Notes

GIS Processing Notes (As Built)

calculated; otherwise
NODATA.

vector layer of street segments.
When buffering, select “merge polygons”.
This raster layer will be used to mask OUT all areas that are
beyond the buffer.

Output Layers:

Resolution: _____ meters

Other Comments:

Data Download
 NA
UTRI Model
 Run model to sum individual layer
cell values
ArcToolbox
ATB=>Spatial Analyst Tools=>Map
Algebra=>Raster Calculator
ATB=>Spatial Analyst
Tools=>Reclass=>Reclassify

07_UTRI-Index

Data Download
 NA
UTRI Model
 NA
ArcToolbox
 Convert UTRI raster to vector and
assign UTRI risk rating to street
segments for field verification and
stratification components.
ATB=>Conversion Tools=>From
Raster=>Raster to Polygon
and…
ATB=>Analysis
Tools=>Overlay=>Spatial Join
or possibly…
ATB=>Analysis
Tools=>Overlay=>Identify
or possibly…
ATB=>Analysis Tools=>Overlay=>Union

08_UTRI-R2V

UTRI Model
 NA
ArcToolbox
 Can use Crystal Reports, or read DBF
in Excel or other spreadsheet to
generate report

NA

UTRI Model
 NA
ArcToolbox
 NA
Other Tools
 Stratified Sampling Tools

5

Coordinate System: ___________________________________________

NA

rUTRIsum
rUTRI

vUTRI

UTRI_S (cell)
UTRI_F (cell)
UTRI_A (cell)
UTRI_P (cell)
UTRI_T (cell)

NA

NA

NA

Cell Value

Cell values summed
to UTRI
(grid_code)

NA

NA

Classification- Try
Quantile, Natural Breaks
(Jenks) or other symbol
classification technique
to create four or five
classes.
Once break points are
determined use the
raster reclassify tool to
create a final reclassified
raster layer.

Reclassification of input layers may be performed to create
more suitable risk index upon summation.
Use ArcMap RC=>Properties->Symbology dialog to view the
Jenks Natural Breaks to set and test breaks in the data prior to
reclassification.
The final rUTRI layer is created from the reclassification of this
rUTRIsum into four classes: 1:Low, 2:Moderate, 3:High, and
4:Very High.
See Appendix D for Raster Calculator details for syntax and
weighting of layers.

Input Layers:

NA

After conversion to a polygon layer, the original street layer
(AOI_Street) is assigned the corresponding UTRI value
(obtained in the conversion from raster). A street segment
may intersect from 1 to n raster cells that are summed into
the final UTRI and assigned to the street layer.
Note: Only integer raster layers can be converted to polygon
features. If you create a floating point rater in step 7 you will
need to convert it to integer for this step (see Appendix D).

Input Layers:

Generates street segment field verification form from street
layer for urban forester. Includes a color coded map(s) and
corresponding list(s) of street segments keyed to map.
Generates standard UTRI map from an ArcMap template.
Updated street segment map (and list) after verification is
used for:
1. Comprehensive risk management (risk zones)
2. Tree risk assessment and rating
3. Pre-disaster mitigation
4. Urban forest management (planting)

Input Layers:

Biogeography Branch’s Sampling Design Tool for ArcGIS
http://ccma.nos.noaa.gov/products/biogeography/sampling/
or Hawth's Analysis Tools for ArcGIS v9.3
http://www.spatialecology.com/htools/overview.php
or the Geospatial Modeling Environment
http://www.spatialecology.com/gme/
or Iowa State PM2082-09n Using Field Calculator: Create
Random Values.
www.extension.iastate.edu/Publications/PM2082-09N.pdf

Input Layers:

NA

NA

GIS Data Preparation and Processing
CARPDC, Montgomery, Alabama

Output Layers:

Other Comments:

Output Layers:

Other Comments:

Output Layers:

Other Comments:

Output Layers:

Other Comments:
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100

Additional UTRI Model Processing Notes:

101

GIS data source (and quality) will control the amount of editing needed prior to using the model and the quality
and functionality of the model output (i.e. the risk index calculated, field forms, reports, and maps). The notes
below will provide some indication of the most important considerations when using the data and model. Editing
may also be influenced by data processing and reporting standards within your agency.

102
103
104
105

Step 1: Assemble Data Layers Needed

106

Obtain necessary layers (often as ERIS ArcGIS shapefiles) that will be needed in Steps 1-10 (AOI, streets,
facilities, population, canopy). Layers not required by the model may also be obtained and used to develop
more familiar map products for reports and field use (e.g. adding a stream network gives field crews additional
landscape reference points).

107
108
109

111

The project resolution (size of the raster cells) will probably be controlled by the tree canopy layer which will be
the only source data acquired that is a raster layer.

112

Step 2: Create a Personal/File Geodatabase for the Project

113
114

A well defined folder structure and geodatabase, while not required, will help organize your original data layers
needed for the model and the intermediate and final layers needed to complete UTRI modeling.

115

If a geodatabase is not used then you may also want to create a folder for “FinalModelLayers”.

116
118

The “SourceData” folder may also have subfolders for the major modeling components: Boundaries,
Transportation, Facilities, Canopy, and Others. This is particularly helpful if significant editing and data
manipulation is required prior to importing the data layer into the project geodatabase.

119

Step 3: Create Project Boundary

120

Input:

Vector features needed to create the combined area of interest for the urban tree risk
assessment.

122

Output:

A vector feature (polygon) that represents the AOI; it may or may not have an edge buffer.

123

The UTRI Model, while originally intended for a county focus, may be used for any smaller or larger area of
interest (AOI) desired. Regardless of the spatial extent of your AOI the type of reporting should be determined
at the beginning of the process (e.g. at the AOI or sub-AOI levels). For example, if the AOI is a county but you
also intend on reporting at the municipal level within the county then municipal boundaries will be needed at
the reporting and map generation stages. In addition, if those municipal boundaries cross county lines then
adjacent county data (e.g. tree canopy, population, streets, facilities) will be need for the analysis.

110

117

121

124
125
126
127
128

130

Once the final AOI boundary is determined a buffer may be desirable/useful particularly when modeling an
area that is not based on political boundaries.

131

Step 4: Process Streets (Targets)

132

Input:

Vector features (lines) representing public streets and roads.

133

Output:

A raster feature that represents the street right-of-way (ROW) with the cell values rated for risk
(e.g. from 0-4) based on street type (MTFCC); UTRI_T is the vector layer attribute to use when
creating the raster.

129

134
135
136

Three types of Census TIGER/Line files are available for streets in shapefile format.
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137

At the Census TIGER/Line website: use Features=>Roads.

138

141

These include: “primary and secondary roads” and “all roads”. Downloaded files have the file name
structure like:
 tl_2010_01_prisecroads.zip
 tl_2010_01051_roads.zip

142

These are typically 1:100000 scale derived centerlines (check the metadata).

143

At the Census TIGER/Line website: use Features=>All.

144

This will be the “edges” file that includes all lines for the county; streets can be created as a subset using
the ROADFLG attribute (Menu=>Selection=>Select by attributes).

139
140

145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170

Downloaded files have the file name structure like:
 tl_2010_01051_edges.zip
These are at a 1:24000 scale (check metadata) that have streets broken into smaller segments. For
example, in Elmore County (AL) the 1:24000 scale street file contains 12,000+ segments while the
1:100000 street file contains only about 5,000 segments. Either may be used for the UTRI modeling.
The data structure of TIGER files may contain many attributes not needed for this model: Recommended
minimum requirements are unique street ID (not FID or OBJECTID), street name, road classification, and length.
Ideally the street name should be the base name of the street including the type modifier as suffix (i.e. Street,
Highway, Road, Boulevard, Circle, Court, etc. or their abbreviations); any direction prefix should be at the end
of the name or in a unique attribute (e.g. “High St N” not “N. High St”). The street name attributes may have to
be manipulated into this format if desired.
The “edges” file also contains the address range of the street segment. The address ranges in these files
(LFROMADD, LTOADD, RFROMADD, RTOADD) do not consistently have the lowest number (or highest) in the
“from” component. A more readable field report form can be created if a new attribute is created (a text field)
that assembles the block address range that consistently runs from smallest address to largest and that always
looks at the right addresses (or left if there are no rights).
This is the first of two GIS street layers needed for the UTRI model.
1. all roads are needed to develop a risk prioritized street layer based on the type of road (using the
attribute MTFCC or similar)
2. primary and secondary street GIS layer that includes federal and state highways is used in the critical
facility layer processing step
For “all roads” (or “edges”) processing the street centerlines are buffered to a distance that will encompass any
street-side trees that could affect the public ROW (right-of-way). We currently use 50’ from the centerline for a
combined buffered street width of 100’. Other widths may be appropriate for your analysis and should be used
as desired.
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171

Step 4a: Process Facilities (Targets)

172

Input:

Vector features (points) representing critical facilities in the AOI.

173

Output:

A raster feature that represents the area of concern near the facility with the cell values rated for
risk (e.g. from 0-4) based on facility type; UTRI_F is the vector layer attribute to use when
creating the raster.

174
175
176
177
178
179
180
181
182
183
184

The facilities will be represented in the UTRI model by two components:
1. a simple circular zone (e.g. 100 meter or 200 meter radius) that accounts for the “immediate area”
near the facility, and
2. streets or street segments that support the facility (i.e. access to/from the facility)
The first facility layer is a simple point buffer (e.g. 100 or 200 meters) with the type of facility rating reclassified
and assigned to UTRI_F and converted to a raster layer.
Note: If file errors occur for “Input Features” in the Feature to Raster (or Polygon to
Feature) dialog try using the folder selection icon and select the vector (polygon) file
from the geodatabase (or list of shapefiles).

185

Input:

Vector features (points) representing critical facilities in the AOI.

186

Output:

A vector feature (polygons) that will encompass primary and secondary roads of importance for
this facility; carries the UTRI_F from the facility.

187

191

The second facility layer (used in step 4b that follows) is a larger buffer on the highest ranked facilities (e.g. the
top two facility rating classes) that will be used to select access routes to and from these facilities. For this
buffer use 3000 meters to 5000 meters. Use the same UTRI_F value assigned in the “immediate area” buffer.
This is the Facility Zone layer (e.g. vFacilityZone) and does not have to be converted to a raster.

192

Step 4b: Process Streets (Access to Facilities)

193

Input:

A vector feature (polygons) that will encompass primary and secondary roads of importance for
this facility; carries the UTRI_F from the facility; from 4a.

Output:

A raster feature that represents the street right-of-way (ROW) with the cell values rated for risk
(e.g. from 1-n) based on cumulative UTRI_F of all facilities that depend on the particular street or
street segment; UTRI_C is the vector layer attribute to use when creating the raster.

188
189
190

194
195
196
197
198
199
200
201
202
203
204
205
206

This is the second of two GIS street layers needed for the UTRI model.
1. all roads are needed to develop a risk prioritized street layer based on the type of road (using the
attribute MTFCC or similar)
2. primary and secondary street GIS layer that includes federal and state highways is used in the critical
facility layer processing step
For “primary and secondary” processing the street segments are spatially selected using the facility zones and
the facility risk ratings (UTRI_F) are cumulatively assigned to UTRI_C. This creates a second street layer that
represents the overall importance (or risk) that specific streets have for access to and from facilities. This layer
is converted to a raster.
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207

Step 5: Process Population (Targets)

208

Input:

A population layer (feature); may be either vector (e.g. Census blocks) or raster (e.g. LandScan).

209

Output:

A population raster layer with the cell values rated for risk (e.g. from 0-4) based on population
density (e.g. population/square mile; UTRI_P is the vector layer attribute to use when creating
the raster.

210
211
212
213
214
215
216
217
218
219
220

This step begins with either a Census polygon or LandScan raster. Data manipulation is done in a vector layer
(polygon) so raster to vector conversion may be necessary to being (projection and datum may be set at that
time).
Note: If converting an input population raster to a polygon feature do NOT “simplify
polygons” (i.e. leave that optional box in the conversion dialog unchecked).
Other ArcGIS extensions (like XTools) can be used to calculate area in square miles.
Note: If using the attribute table’s “Field Calculator” to calculate population/square
mile, a “Select by Attribute…” should be made for areas > 0 square miles to avoid a
“divide by zero” error.

222

The natural breaks facility in RC: Properties=>Symbology can be used to help visually set the classification
breaks for the reclassification.

223

Step 6: Process tree canopy (Potential Tree Failure)

224

Input:

A raster layer that has cell values for percent tree canopy or (on higher resolution urban tree
canopy (UTC) layers the landcover (e.g. water, canopy, impervious, bare soil, and grass).

Output:

A tree canopy raster layer with the cell values rated for risk (e.g. from 0-4) based on canopy
density.

221

225
226
227
228

If using NAIP or other imagery use or convert to project resolution during classification.

229
230

When clipping raster layers from within ArcMap and using Data Management Tools=>Raster=>Raster
Processing=>Clip check () the “Use input features” to clip with AOI boundary.

231

Step 6a: Create AOI Mask

232

Input:

Vector features (lines) representing public streets and roads in Step 3.

233

Output:

A raster layer that will be used to “mask out” areas of the AOI of no interest (e.g. areas that are
not near streets or public facilities. The cell values are set to 1 and areas of no interest are set to
NODATA.

234
235

237

Create a vector (polygon) layer by buffering the street centerline from Step 3. The buffer should exceed the
buffer used to create vStreet and rStreet and is approximately 3x the distance (e.g. 150’) from the centerline.

238

[combine polys; then set 1 attrib to value of 1]

239

This raster layer will be used to mask OUT all areas that are beyond this buffer.

236
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240

Step 7: Create UTRI Layer (Raster)

241

Input:

Raster layers: rStreet, rFacility, rCFstreet, rPopulation, rCanopy, rAOImask

242

Output:

An intermediate raster layer (rUTRIsum) that sums the input layers and a final raster layer (rUTRI)
that is reclassified into four classes that correspond to risk zones in Urban Tree Risk
Management: A Community Guide to Program Design.

243
244
245

Step 8: Create UTRI Layer (Vector)

246

Input:

rUTRI

247

Output:

A vector (polygon) layer (e.g. vUTRI) that can be used to update the street layer with the UTRI for
the segment. Or combine the segment UTRI value with the street segment in some fashion.

248

251

The conversion to a polygon is simply TB=>Conversion Tools=>From Raster=>Raster to Polygon. Various GIS
methods may be used to accomplish this final task that produces the layer used for the map and field report
that includes both UTRI and the unique segment identification.

252

Step 9: Create Field Verification Report

253

Input:

vUTRI or vStreet (updated with UTRI)

254

Output:

A listing of the street segments sorted alphabetically by street and in descending order of UTRI.
Unique segment indices are used on corresponding map for field checks.

249
250

255
256

This can be accomplished through the attribute table for the layer and Reports=>Create report.

257

Step 10: Produce a Stratified Random Sample for Debris Estimation

258

Input:

vUTRI or vStreet (updated with UTRI)

259

Output:

A list of the street segments (plots) randomly selected by strata.

260

Various GIS methods may be used to accomplish this task that randomly selects street segments (as plots) for
debris estimation samples. Each UTRI value (1 through 4) is treated as strata. Plots selected should be
approximately:

261
262
263
264
265
266
267
268
269
270






UTRI 4: 40%
UTRI 3: 30%
UTRI 2: 20%
UTRI 1: 10%

The final street segment layer (e.g vUTRI or vStreet) that contain the UTRI can be modified to add an attribute
RANDSEL and in the field calculator fill each record using the function: Rnd. Generate randm numbers for each
strata between 0 and 1. Then, for example, if you are interested in 20% of the segments in that stratum,
merely take all segments with a random number ≤ 0.2.
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271

ArcGIS Raster Calculator & NODATA Values:

272

Raster layers (i.e. ESRI GRIDS) may be created for streets, facilities, facility access, population, and canopy with
NODATA cell values (i.e. null values NOT zeroes). In the final step of the UTRI model, where the raster layers are
6
7
summed, the following or similar syntax should be used :

273
274

with a layer weighting factor…
(Con(IsNull("LAYER1"),0,"LAYER1") * 1.0)+\
(Con(IsNull("LAYER2"),0,"LAYER2") * 1.0)+\
(Con(IsNull("LAYER3"),0,"LAYER3") * 1.0)+\
(Con(IsNull("LAYER4"),0,"LAYER4") * 1.0)+\
(Con(IsNull("LAYER5"),0,"LAYER5") * 1.0)+\
(Con(IsNull("AOIMASK"),"AOIMASK",0))

275
276
277
278
279
280
281

without a layer weighting factor…
Con(IsNull("LAYER1"),0,"LAYER1") +\`
Con(IsNull("LAYER2"),0,"LAYER2") +\
Con(IsNull("LAYER3"),0,"LAYER3") +\
Con(IsNull("LAYER4"),0,"LAYER4") +\
Con(IsNull("LAYER5"),0,"LAYER5") +\
Con(IsNull("AOIMASK"),"AOIMASK",0)

282
283
284
285
286
287
288
289

The “IsNull” function evaluates each raster cell and returns a “true” (i.e. value of 1) if the cell is NODATA.

290

The “Con” function is a conditional statement that substitutes a zero (0) if the cell is currently NODATA, otherwise it
uses the value found.

291
292
293
294
295
296
297

AOIMASK is a raster layer that has a cell value of one (1) only in the area that you would like to evaluate for the final
risk layer (e.g. rUTRI). The conditional statement with this layer is reversed so that NODATA values remain and
other values are replaced with zero (0) so that the mask does not affect the cumulative result (i.e. only the layers
for: streets, facilities, access to facilities, population, and canopy contribute values for summation).
The desired code above may be copied and pasted into the raster calculator; then change the “LAYERn” names
appropriately for your project.

6
7

Function names ARE case sensitive.
The back slash character “\” is the line continuation indicator.
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300

During the summation into the final combined layer (i.e. rUTRI) the layers may optionally be weighted by
modifying the component “* 1.0”. For example, use “* 2.0” to make a layer 2x its calculated weight, or “* 0.5” to
make it ½ the calculated weight.

301

Actual example with layer names substituted and no weighting:

298
299

302
303
304
305
306
307
308
309

Int( \
(Con(IsNull("rElmoreTallassee_Streets_2"),0,"rElmoreTallassee_Streets_2") * 1.0) + \
(Con(IsNull("rElmoreFacilities200m_2"),0,"rElmoreFacilities200m_2") * 1.0) + \
(Con(IsNull("rElmoreTallassee_CFS_ZoneArea_2"),0,"rElmoreTallassee_CFS_ZoneArea_2") * 1.0) + \
(Con(IsNull("rLandScan2009UTM16N"),0,"rLandScan2009UTM16N") * 1.0) + \
(Con(IsNull("rCanopyRC2"),0,"rCanopyRC2") * 1.0) + \
(Con(IsNull(“rAOImask50m”), “rAOImask50m”,0)) \
+ 0.5)

310

Integer and Floating Point (i.e. Real) Raster layers:

311

The raster layer resulting from a calculation using real number weighting factors will be a floating point raster.
Floating point raster layers cannot be converted to polygon features. If a final polygon feature (e.g. vUTRI) is
needed (e.g. for reporting) then it must first be converted to an integer raster layer.

312
313
314
315
316

The example above uses the Int() function to convert the final summation to an integer raster during the one pass
through the raster calculator. The constant 0.5 is added to each floating point raster cell value from the main
calculation to force rounding (as opposed to truncation).

318

Alternatively, if weighting factors are only required to be whole numbers (e.g. 1, 2,3) then using them without a
decimal (e.g. 1.0) will create an integer raster as needed.

319

And finally, if the floating point raster is to be reclassified, the conversion to integer can occur at that time.

317
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