
Appendix A 

Local Disaster Planning, Mitigation, Response, and Recovery  July 25, 2012 

Urban Tree Risk Index (UTRI) Model v 1.09 

Objective: Users will step through the model, format input data layers from multiple sources, and create five raster layers that can be summed to create the UTRI.  The final UTRI is then assigned back to the street segment layer for field verification, urban forest risk management, disaster 
planning, debris stratification, and/or response prioritization. 
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GIS Data Preparation and Processing  Page: 4 
CARPDC, Montgomery, Alabama 

 C:\Documents and Settings\dhartel\My Documents\Dropbox\Forest Service\UTRI-CARPDC\Documents\2012 UTRI Data Process and GIS Tool Description (25Jul12 v1.09TableRevision).docx 

Process Step Data Source GIS
3
/Model Processing

4
 Model Tools Data Layer(s)

5
 Input Attribute Output Attribute Assignment or Reclass Model Notes GIS Processing Notes (As Built) 

1 Assemble data layers needed 
(see Data Source column for 

steps -). 

Create a folder & subfolders 
for the project; for example: 

…\UTRI2012Elmore 
…\UTRI2012Elmore\So
urceData 
…\UTRI2012Elmore\M
aps 
…\UTRI2012Elmore\Do
cuments). 

See below in this 
column and Notes 
column links. 

NA NA NA NA NA NA http://www.census.gov 

http://www.mrlc.gov 

https://www.hifldwg.org 

Other local/regional/state sources 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

2 Create an ArcMap 
personal/file geodatabase 
and map document (i.e. 
project) in the project “root” 
folder from the previous 
step. 

Set the default geodatabase. 

NA ArcCatalog 

 Create/select folder 

File=>New Personal Geodatabase 

ProjectNameDate 

ArcMap 

File New… 

Dialog=>Default geodatabase 

NA NA NA NA NA The geodatabase is an excellent file/layer organizational tool 
and may also function as process documentation.  It should 
hold all intermediate layers used in the processing as well as 
the final vector and raster layers. 

An example ProjectNameDate might be: 

UTRI2012Elmore.mdb 

The original supporting data (e.g. NLCD or Census) does not 
have to be placed into the geodatabase. 

Set projection and datum for the geodatabase and then make 
it the ‘default’ geodatabase when you create your map 
document (i.e. the mxd; the ‘project’). 

Note: Users may opt to use ArcGIS shapefiles and stand-alone 
raster files if desired.  Layer name may be used as the 
shapefile and raster file names. 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

3 Create project boundary; i.e. 
the area of interest (AOI) 

2010 Census 
TIGER Lines -  
Geographic 
Areas=>Counties 
(and equivalent) 

Data Download 

 Census data or other 

UTRI Model 

 Select feature (AOI) 
 Extract AOI feature 
 Buffer to 1k or desired distance 
 Project to project coordinates 

ArcMap 

TB=>Select Feature (e.g. County) 

RC=>Data=>Export Data 

ArcToolbox 

Analysis Tools=>Proximity=>Buffer 

02_UTRI-AOI AOI_Region 
AOI_County 
AOI_City 
AOI_Other 

NA NA NA Source: http://www.census.gov/cgi-
bin/geo/shapefiles2010/main. 

Use UTRI model tool or ArcToolbox. 

This step may include multiple levels (e.g. county, 
municipality, neighborhood). 

Intermediate layer names should lead to or reflect the final 
layer to be used by UTRI; e.g. 

AOI_CountyCensus (i.e. first data export layer) 

AOI_County (i.e. after projection and datum set) 

AOI_County1k (e.g. 1 kilometer buffer) 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

4 Process streets (Targets) 2010 Census 
TIGER Lines  - 
Features => All 
Lines (i.e. 
“edges”) 

or… 

Features => Roads 
=>All 

Data Download 

 Census data or other 

UTRI Model 

 Add UTRI_T (set to 0) 
 Clip with AOI 
 Project to project coordinates 
 Classify 
 Buffer to right-of-way (ROW) extent 

ArcToolbox 

 Convert to raster at project 
resolution 

ATB=>Conversion Tools=>To 
Raster=>Feature to Raster 

03_UTRI-Street 

03_UTRI-Blocks 

AOI_Street 

vStreet 

rStreet 

MTFCC UTRI_S to raster 
cell 

UTRI_S & Cell: 

S1100 = 4 

S1200 = 3 

S1300/S1400 = 2 

Others important to 
your community = 1 

All else = 0 

Source: http://www.census.gov/cgi-
bin/geo/shapefiles2010/main. 

UTRI_S is an integer value. (STREET) 

Use 50’ buffer from centerline or appropriate width based on 
street type for the segment or other local knowledge to create 
the polygon vector layer of street segments. 

Trees within the street buffer represent the area of concern 
for disaster planning if they can adversely affect people, 
facilities, or transportation. 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

4a 
Process facilities (Targets) 

 

 

 

 

 

 

 

 

 

 

Local or 
HSIP Gold 

Data Download 

 Data as available 

UTRI Model 

 Add UTRI_F (set to zero) 
 Clip with AOI 
 Project to project coordinates 
 Classify 
 Buffer facility vicinity 

ArcToolbox 

 Convert to raster at project 
resolution 

04_UTRI-Facility AOI_Facility 

vFacility 

rFacility 

 

 

 

 

 

 

 

 

Name or 
description 

UTRI_F to raster 
cell 

 

 

 

 

 

 

 

 

 

UTRI_F & Cell: 

Hospitals=5 

Fire, Police, Emergency 
Management Center = 
4 

Communication 
Towers, Water 
Treatment Plants, 
Water Towers, Waste 
Water Treatment Plants 
= 3 

Schools, Parks, and 

Source: Local or HSIP CD. 

UTRI_F is an integer value. (FACILITY) 

Buffer the facilities with a 100 meter or 200 meter radius. 

This represents the “immediate area” of risk for each critical 
facility. 

 

 

 

 

 

 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

                                                      
3
 ArcGIS is ArcCatalog, ArcMap, ArcToolbox, and ArcGIS Extensions; TB refers to ArcMap menu tools & toolbars; ATB refers to the ArcToolbox, TOC is the ArcMap table of contents, RC is ‘right-mouse click’; Dialog is the input dialog window from a menu selection (e.g. New…). 

4
 “=>” Indicates ArcGIS  menu selections. 

5
 Suggested layer names; AOI is area of interest and used for clipping. Some steps will have multiple layers; use v prefix for vector and r prefix for raster in those cases (e.g. vStreet and rStreet represent the same data). 

http://www.census.gov/
http://www.mrlc.gov/
https://www.hifldwg.org/
http://www.census.gov/cgi-bin/geo/shapefiles2010/main
http://www.census.gov/cgi-bin/geo/shapefiles2010/main
http://www.census.gov/cgi-bin/geo/shapefiles2010/main
http://www.census.gov/cgi-bin/geo/shapefiles2010/main
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Process Step Data Source GIS
3
/Model Processing

4
 Model Tools Data Layer(s)

5
 Input Attribute Output Attribute Assignment or Reclass Model Notes GIS Processing Notes (As Built) 

 

 

 

 

Process facilities  

(for Step 4b that follows) 

ATB=>Conversion Tools=>To 
Raster=>Feature to Raster 

 

 

 

Data Download 

 Data as available 

UTRI Model 

 NA 

ArcToolbox 

ATB=>Analysis 
Tools=>Proximity=>Buffer 

 

 

 

 

vFacilityZone 

 

 

 

 

UTRI_F 

other locations where 
people congregate = 2 

Others important to 
your community = 1 

All else = 0 

 

 

 

 

UTRI_F is an integer value as assigned in vFacility. 

Selected critical facilities (e.g. use two highest UTRI_F levels) 
should be buffered to a distance of 3000 meters to 5000 
meters and used in the next step that identifies critical routes 
for these facilities in the AOI. 

4b Process streets (Access to 
Facilities) 

2010 Census 
TIGER Lines  -  

Features => Roads 
=> 
Primary/Secondar
y 

vFacilityZone 

Data Download 

 Data as available 

UTRI Model 

 Add UTRI_C (set to zero) 

ArcMap Tools 

 Cumulative UTRI_F into UTRI_C 

RC=>[TOC Layer] Open Attribute Table  

TB=>Selection=>Select by attribute 

TB=>Selection=>Select by location 

RC=>[Attribute Name] Field Calculator 

ArcToolbox 

 Convert to raster at project 
resolution 

ATB=>Conversion Tools=>To 
Raster=>Feature to Raster 

NA vCFstreet 

rCFstreet 

UTRI_F UTRI_A to raster 
cell 

Cumulative UTRI_A from 
the critical facility zones 
layer. 

UTRI_Ais an integer value. (ACCESS) 

This will be the GIS layer of primary roads in the AOI; assigned 
the risk ratings for all facilities that depend on that particular 
street or street segment; segment risk is cumulative for all 
critical facilities (CF) in vFacilityZone. 

When making calculations for street segment rating for facility 
access: 

work alternatively in two layers: vFacilityZones, vCF_Streets 

set all UTRI_C to one (1) in v_CF_Streets 

use a “Select by Attributes…” for UTRI_F > x (rating desired) 

calculate UTRI_C = UTRI_C + x 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

5 Process population (Targets) 2010 Census or 
HSIP LANDSCAN 

Data Download 

 Census data or other 

UTRI Model 

 Extract population in AOI 
 Convert to vector (polygon) 
 Project to project coordinates 
 Calculate square miles (=acres/640; 

=square feet/27878400; =square 
meters/2589988) 

 Calculate population/square mile 
 Reclassify 

ArcToolbox 

 Convert to raster at project 
resolution 

ATB=>Conversion Tools=>To 
Raster=>Feature to Raster 

05_UTRI-Census vCensus 

rCensus 

 SqMiles 

Pop_SqMile 

UTRI_P to raster 
cell 

Classification- Try 
Quantile, Natural Breaks 
(Jenks) or other symbol 
classification technique 
with four or five classes. 

UTRI_P & Cell: 

Class 5 = 4 

Class 4 = 3 

Class 3 = 2 

Class 2 = 1 

Class 1 = 0 

Source: http://www.census.gov/cgi-
bin/geo/shapefiles2010/main. 

Source: Local or HSIP CD. 

UTRI_P is an integer value. (POPULATION) 

When making calculations for population density: 

set all Pop_SqMile to zero (0) 

use a “Select by Attributes…” for areas > 0 (square miles) 

calculate Pop_SqMile = Population/SqMiles 

Areas with zero population / square mile should be set to 
UTRI_P = 0. 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

6 

 
 
 
 
 

Process tree canopy 
(Potential Tree Failure) 

NLCD (USGS) 

NAIP (FSA) 

Data Download 

 Most current NLCD tree canopy 
 Or, local tree canopy 
 Or, classify most recent NAIP 

UTRI Model (NLCD) 

 Clip to buffered AOI 
 Reclassify (raster operation) 
 Project to project coordinates 

ArcToolbox 

ATB=>Data Management 
Tools=>Raster=>Raster 
Processing=>Clip  

ATB=>Data Management 
Tools=>Projections and 
ATB=>Transformations=>Raster=>Proj
ect Raster 

ATB=>Spatial Analyst 
Tools=>Reclass=>Reclassify 

06_UTRI-Canopy AOI_Canopy 

rCanopy 

Cell Value Cell value (UTRI_T) Classification- Try 
Quantile, Natural Breaks 
(Jenks) or other symbol 
classification technique 
to create from five or 
eleven classes. 

Cell (UTRI_T): 

91-100 = 10 

81-90 = 9 

71-80 = 8 

61-70 = 7 

51-60 = 6 

41-50 = 5 

31-40 = 4 

21-30 = 3 

11-20 = 2 

1-10 = 1 

0 = 0 

Tree canopy is available from the MRLC: 
http://www.mrlc.gov/index.php 

The National Land Cover Database (NLCD 2001) tree canopy 
layer is downloaded as a raster and the cell value represents 
percent of tree canopy (from 0 to 100%) for the 30 meter 
pixel. 

This is a single file for the entire coterminous US and is in the 
Albers projection and in meters, WGS84. 

The MRLC Consortium Viewer at: 
http://gisdata.usgs.gov/website/mrlc/viewer.htm 
can be used to download an area that includes a single or 
multiple counties (not by county boundary but by rectangular 
selection area that you estimate will include your AOI).  This 
raster file can then be clipped with the AOI. 

When downloading from the viewerthe default is to get the 
landcover dataset.  To specify tree canopy, click on the 
download tab (in the right panel), and uncheck landcover and 
select tree (forest) canopy). 

Then make your download area with the selection box tool (in 
the left panel near the bottom). 

ArcGIS Spatial Analyst Extension is required for most of the 
operations in this and the following steps. 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

6a Area of Interest Mask vStreet Data Download 

 Streets from Step  

 vAOImask 

rAOImask 

Select any 
integer attribute 
with a value of 1 

Cell Assign value of 1 to the 
areas within the AOI that 
should have a risk index 

Use approximately 3x the distance used in Step 3; 150’ buffer 
from centerline or appropriate width based on street type for 
the segment or other local knowledge to create the polygon 

Input Layers: 
 

http://www.census.gov/cgi-bin/geo/shapefiles2010/main
http://www.census.gov/cgi-bin/geo/shapefiles2010/main
http://www.mrlc.gov/index.php
http://gisdata.usgs.gov/website/mrlc/viewer.htm
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Process Step Data Source GIS
3
/Model Processing

4
 Model Tools Data Layer(s)

5
 Input Attribute Output Attribute Assignment or Reclass Model Notes GIS Processing Notes (As Built) 

UTRI Model 

 Buffer to a distance that exceeds 
right-of-way (ROW) extent 

ArcToolbox 

 Convert to raster at project 
resolution 

ATB=>Conversion Tools=>To 
Raster=>Feature to Raster 

(or due field 
calculator to set 
it) 

calculated; otherwise 
NODATA. 

vector layer of street segments. 

When buffering, select “merge polygons”. 

This raster layer will be used to mask OUT all areas that are 
beyond the buffer. 

 
Output Layers: 

 

 

Other Comments: 

7 Create UTRI (Raster) rStreet 

rFacility 

rCFstreet 

rCensus 

rCanopy 

rAOImask 

Data Download 

 NA 

UTRI Model 

 Run model to sum individual layer 
cell values 

ArcToolbox 

ATB=>Spatial Analyst Tools=>Map 
Algebra=>Raster Calculator 

ATB=>Spatial Analyst 
Tools=>Reclass=>Reclassify 

07_UTRI-Index rUTRIsum 

rUTRI 

UTRI_S (cell) 

UTRI_F (cell) 

UTRI_A (cell) 

UTRI_P (cell) 

UTRI_T (cell) 

Cell Value Classification- Try 
Quantile, Natural Breaks 
(Jenks) or other symbol 
classification technique 
to create four or five 
classes. 

Once break points are 
determined use the 
raster reclassify tool to 
create a final reclassified 
raster layer. 

Reclassification of input layers may be performed to create 
more suitable risk index upon summation. 

Use ArcMap RC=>Properties->Symbology dialog to view the 
Jenks Natural Breaks to set and test breaks in the data prior to 
reclassification.  

The final rUTRI layer is created from the reclassification of this 
rUTRIsum into four classes: 1:Low, 2:Moderate, 3:High, and 
4:Very High. 

See Appendix D for Raster Calculator details for syntax and 
weighting of layers. 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

8 Create UTRI (Vector) rUTRI Data Download 

 NA 

UTRI Model 

 NA 

ArcToolbox 

 Convert UTRI raster to vector and 
assign UTRI risk rating to street 
segments for field verification and 
stratification components. 

ATB=>Conversion Tools=>From 
Raster=>Raster to Polygon 

and… 

ATB=>Analysis 
Tools=>Overlay=>Spatial Join 

or possibly… 

ATB=>Analysis 
Tools=>Overlay=>Identify 

or possibly… 

ATB=>Analysis Tools=>Overlay=>Union 

08_UTRI-R2V vUTRI NA Cell values summed 
to UTRI 

(grid_code) 

NA After conversion to a polygon layer, the original street layer 
(AOI_Street) is assigned the corresponding UTRI value 
(obtained in the conversion from raster).  A street segment 
may intersect from 1 to n raster cells that are summed into 
the final UTRI and assigned to the street layer. 

Note: Only integer raster layers can be converted to polygon 
features.  If you create a floating point rater in step 7 you will 
need to convert it to integer for this step (see Appendix D). 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

9 Create field verification 
report 

NA UTRI Model 

 NA 

ArcToolbox 

 Can use Crystal Reports, or read DBF 
in Excel or other spreadsheet to 
generate report 

NA  NA NA NA Generates street segment field verification form from street 
layer for urban forester.  Includes a color coded map(s) and 
corresponding list(s) of street segments keyed to map. 

Generates standard UTRI map from an ArcMap template. 

Updated street segment map (and list) after verification is 
used for: 

1. Comprehensive risk management (risk zones) 
2. Tree risk assessment and rating 
3. Pre-disaster mitigation 
4. Urban forest management (planting) 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

10 Produce a stratified random 
sample (street segments) for 
debris estimation in i-Tree 
Eco or i-Tree Streets. 

Produce UTRI street segment 
map. 

NA UTRI Model 

 NA 

ArcToolbox 

 NA 

Other Tools 

 Stratified Sampling Tools 

NA  NA NA NA Biogeography Branch’s Sampling Design Tool for ArcGIS 

http://ccma.nos.noaa.gov/products/biogeography/sampling/ 

or Hawth's Analysis Tools for ArcGIS v9.3 

http://www.spatialecology.com/htools/overview.php 

or the Geospatial Modeling Environment 

http://www.spatialecology.com/gme/ 
or Iowa State PM2082-09n Using Field Calculator: Create 
Random Values. 

www.extension.iastate.edu/Publications/PM2082-09N.pdf 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

http://ccma.nos.noaa.gov/products/biogeography/sampling/
http://www.spatialecology.com/htools/overview.php
http://www.spatialecology.com/gme/
http://www.extension.iastate.edu/Publications/PM2082-09N.pdf



