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Overview

Along with the geodatabase model, there are a set of Python scripts that transfer data between

the ArcGIS geodatabase and i-Tree Eco software. This enables the users to quickly derive the tree
inventory’s ecosystem services through the i-Tree Eco model, then spatially display the results

in ArcMap. The first script will create an Access database that is in compliance with i-Tree Eco’s
domains, the second script will copy the data from i-TreeEco feature class to the newly created
Microsoft Access database, while the third script will join the results from the i-Tree Eco model to
the existing feature class to enable visual representation of the ecosystem services.

1. Setting up the dbtools toolbox

**if you have already downloaded and unzipped the iTreeEco_DB zip file skip step 1.
1--> Download the iTreeEco_DB.zip file.
1--> Create a folder in some location on the local machine, say C:\iTreeEco_DB. Do not
include spaces in the name, as spaces cause errors in ArcGIS.
1--> Uncompress iTreeEco_DB.zip by right clicking on the file and choosing the Extract All option.
1--> Choose the folder to be extracted as the one created in the previous step. Click Extract.
1--> Open the iTreeEco_DB folder and locate the folder called pypyodbc.
1--> Inside this folder, find setup.py. Double click on setup.py.

2--> Open ArcMap, and choose a blank map. c-r ol HE-len %
2--> In the ArcCatalog menu, add a folder connection to the Location: [ C:\iTreeEco_dbtools [
folder in which the iTreeEco_DB folder is present. S R
2--> The itree-dbtools toolbox shows up in the catalog when the = £ Ci\Treekco_db
H - H = [ dbtools
its parent fo!der is expanded (Fig. 1.1). =<l
2--> Expand the itree-dbtools toolbox. There should be three -
- + comtypes
scripts: B contypes-1.8.
1-Create MS Access Database : E e
2-Populate MS Access Database § 1-Create M5 Access Databese
_ 3-Get data from iTree for displaying in ArcMap it e
3--> Right click on the first script and choose | @ diooknen- 101
Properties. A pop-up window appears. Figure 1.1 Cogféef;g‘lg to i-TreeEco

3--> Click on the Source tab.

3--> Change the location of the script file to _
path\dbtools\1_create_access_db.py (Fig. 2.2).

-
= 3> Repeat the previous step for the remaining two  General Souce | Parameters | validation | Help. |
SCri ptS Script File:
« The source for the second script is

path\dbtools\2_load_access_database.py | € Vececo_dtoklibosll_cestesces. o =
. The source for the th”‘d Scnpt |S I™ | shovw command windawismhen executing scripb
path\dbtools\3_getdata.py* % Run Python script in process
(note: if you are running ArcGIS 10.1, the Figure 1.2 Assigning the script for the tools

source for the third script is 3_getdatal0_1)

Now that the tool setup is complete, let’s use the tools!
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2. Running the Populate MS Access Database script
4--> Double click on “1- Create MS Access Database” script. The tool window appears.

-
=] 4--> Click the Open Folder button next to the Folder Name field. )
4--> Navigate to the folder where you want to create the MS Access database. Click Open.

4--> Type Tutorial_Fulllnventory under Database Name. Click OK (Fig. 2.1).
4--> If the script runs successfully, the results window should say Succeeded. Close the

window.
5--> Double click on “2- Populate MS Access Database -lojx|
i ; . A
script”. The tool window appears. Folder Name
o I C:\iTreeEco_DB\Tutorial ﬁj
IT:7| 5--> Click the Open Folder button next to the e

MS Access Database field.
5--> Navigate to the folder where you created the Tutori-

. . [
al_Fullinventory MS Access database in the previous
- . OK I Cancel Environments... Show Help >>
tool. Click Open. | | |
Ba Figure 2.1 Create MS Access Database tool window
_I 5--> %IiI%kthe Open Folder button next to the Geodataset -
ield.
1 MS Access Database =
5--> !\IaVIgate to th_e fOIder Where the downloadEd |C:\lTreeEm_D;\Tutorial\Tutwis\_FulInventuly.rndb ﬂ
iTreeEco.gdb is located. e

I C:\iTreeEco_DB\Tutarial\Tutarial_iTreeEco.gdbiFulllnventory_Tutorial EI

5--> Choose the the feature class that contains your full
tree inventory, i.e. C:\iTreeEco_DB\Tutorial_iTreeE-
5--> co.gdb\Fullinventory_Tutorial, and click Add.

5--> Make sure the “Populate MS Access Database” win- =l
dow looks like Figure 2.2, then click Ok. ok | _concel | Enwonments,. | <<iderieh |
5--> If the script runs successfully, the results window Figure 2.2 Populate MS Access DB tool window

should say Succeeded (Fig 2.3). Close the window.

=  6-->In the ArcCatalog menu, right click the x
Tutorial folder and click Refresh. Completed
6--> Notice the error_log_Tutorial_Fullinventory.csv g |
that is added to the Tutorial folder. ,
. ™ Close this dislog when completed successfully
6--> Drag the error_log_Tutorial_Fullinventory file to — r
the Table of Contents. 12373
B 6-->Right-click and choose Open to examine the ot
Attribute Table. Swovectcd ot T Lot 14 1213740 2015
6--> Examine the fields in this error log, then (Elapsed Time: 2.36 seconds)
close the table and remove it from the Table of e

Contents.
Figure 2.3 Successful Results from Populate Access DB tool
The script performs validation, the results of which are stored in a .csv file in the same folder as the MS
Access Database. The error log gives a short description and a brief explanation of the error. The records
which produce errors will not be added to the MS Access database. How- ever, the user can always correct
the errors, and execute this step again in order to include the previously erroneous records.
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3. Working in i-Tree Eco

7--> Download and install the i-Tree Eco software.

7--> Go to Start Menu > All Programs > i-Tree > Eco.

7--> In i-Tree Eco, navigate to File > New Project.

7--> Navigate to the folder where this project is stored. Most preferably, store this project in the
same folder where your Tutorial_iTreeEco.gdb is, i.e. in the Tutorial folder.

7--> Name your project Tutorial, and click Save.

7--> For Input database, choose Create.

7--> In the Save Aswindow that pops up, name the input database Tutorial_input.

7--> For Report database, choose Create.

7--> In the Save Aswindow that pops up, name the input database Tutorial result.

The previous steps created stock databases where the input and results for the i-Tree Eco analysis
will be stored. Now we will configure what type of inventory will be fed into these databases. This
isand important step as the type of inventory is unlque to the iTree Eco geodatabse developed

8--> Now click Configure input.

8--> Location Name type Georgia Tech.
8--> State field navigate the drop-down to

Georgia.
8--> County navigate to DeKalb.
8--> Place navigate to Atlanta.

8--> For the Weather Station ID field click

“Select”

8--> Choose the weather station pin in the
middle of the map. The weather station
ID should be 722190-13874, then press

OK (Fig. 3.1).

9--> In the Series name field type
Tutorial 1.

9--> Next to sampling, select the
“Inventory- 100% census” oval

9--> In the Year type 2015.

9--> Next to Data units: field, select the
“English (inches, feet, acres)” oval

9--> Under Project Options, uncheck the
boxes “Pest Detection” and “Energy
Included”.

9--> Do not edit any information in the
Plot Info or Data Collections
sections.

9--> Make sure the Creating/Configuring
inventories window looks like
Figure 3.2, click Add to Database.

9--> Once we have configured the input,
click Exit.

9--> In the create new project window
click OK.
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Figure 3.1 Selecting Weather Station in new i-Tree Eco Project
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Figure 3.2 Creating new i-Tree Eco Project

Page: 4



Importing the data into i-Tree Eco

Now that the data isin MS Access database and the i-Tree Eco project has been created, it is pos-
sibleto import the data to i-Tree Eco and submit it to the remote server for processing.

10--> In i-Tree Eco, navigate to File > Import Data Inventory,
an Importing pop-up window will appear.
10--> Click Browse in the top of the screen.
10--> Navigate to the FulllnventoryTrees.mdb you created when using the 1- Create MS Access
Database tool in ArcMap, i.e. C:/iTree_EcoDB/Tutorial/Tutorial_Fulllnventory.mdb
Press Open (Fig. 3.3).
10--> Click Import at the top of the screen. This may take a while, please be patient.
10--> The Result tab should be highlighted. This displays the results from the import process
(Fig 3.4).
10--> Close the Importing window.
Now that the tree inventory has been ud [mporting =10y x|
successfully imported into i-Tree Eco, we Georgia Tech — Tutorial _1 — 2015
can submit the data to the remote server, @ IS SSDRERNEL C et co DT dond T Pl ol e
which will process the data, deriving eco- Sowee DataFomat | DAtk T [

. - Mo 113 PN Qq - & l
system services for the tree inventory. Figure 3.3 Importing tree inventory to i-Tree Eco

11--> Go to Tools > Submit Data for processing.

. . . Source Data Famal T Aesult I_
11--> Give the appropriate Contact Information. T TR )
11--> Press Ok to verify your contact information.
11--> Press Yes to confirm that at least 50% of the
study area is within the boundary of the city. e e
11--> Press Ok to the pop-up window that informs oot T ]
you that the data will be processed. (ot mprtd s 1578

Figure 3.4 Results from loading tree inventory

The data has been submitted for processing. The pro- T ——

cessing normally does not take longer than 1 hour. Onge = ™ [eerese sz

the processing is finished, an email will be sent that o | e |
links to your results. Figure 3.5 Loading processed data into i-Tree Eco

12--> When the results are ready, an email will be sent with a zip file name.

12--> In i-Tree Eco, go to Tools > Load Results.

12--> Open the email that was sent to you informing that the i-Tree Eco data has been
processed and is ready for download.

12--> Highlight the .zip file name (will be within the quotes).

12--> Copy and paste the file name into the pop-up window in i-Tree Eco.

12--> Press OK. Once the results are loaded, a pop-up window will appear. Press OK.

12--> Close i-Tree Eco. All of the data is now in the Tutorial_results database, which we
can access using scripts in ArcMap.
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4. Running the Get data from iTree for displaying in ArcMap script

Now the processed inventory data is in the Tutorial_results.gdb, we can use the final tool to bring
these results back into ArcGIS to join the results with the original tree inventory shapefile.

13--> Open ArcGIS if it was closed. Bring the Full-
Inventory_Tutorial shapefile from the Tutori-
al_iTreeEco.gdb into the Table of Contents.

13--> In the itree-dbtools.tbx, double click the
script “3-Get data from iTree for displaying
in ArcMap”.

ﬁl 13--> Click the Open Folder button next for the
Results database field.
13--> Navigate to the folder where Tutorial_re-
sults.mdb is located. This is the database you
created when making the i-Tree Eco Project.

-
QI 13--> Click the Open Folder button next to the Feature

filename field.

13--> Navigate to the folder where the Tutorial_iTreeEco.

gdb is located. Choose
Fullinventory_Tutorial the feature class.

13--> Make sure the “Get data from iTree for displaying
in ArcMap” window looks like Figure 4.2, then click

Ok. This script takes a little while to run.

13--> If the script runs successfully, the results window
should say Succeeded (Fig 2.5). Close the window.

& 3-Get data from iTree for displaying in ArcMap

Results database

I C:\iTreeEco_DBY Tutorial| Tutorial_result.mdb

Feature file name

o |

=101

=

IC:\,iTreeEco_DE'I,TutnriaI'I,Tutnrial_lTreeEcu4gdb'\Fu|I1nvantory_TutnriaI @

I]

Cancel I Envirurmgnts...l Show Help >> I

Figure 4.1 Get data from iTree tool window

3-Get data from iTree for displaying in ArcMap L

Completed

I Close this dialog when completed successfully

g

<< Details |

'report_IndividualTreeEffects_nativetos ;]

tate',

Y report_IndividualTreeEffecr.s_X‘ ,
'report_IndividualTreeEffects_Y']
Done

Completed script getData...

Succeeded at Tue Apr 28 01:47:35 2015
(Elapsed Time: 1 minutes 13 seconds)

v

If the script runs successfully, three geodatasets are produced:

Fullinventory_Tutorial_IndividualtreeEffects;

Fullinventory_Tutorial_IndividualTreePollutionEffects;
and Fulllnventory_Tutorial_IndividualtreeOtherEffects.
The feature classes contain data from the i-Tree Eco results, and are produced in the

Tutorial_Fulllnventory geodatabase (Fig. 4.3).

Displaying Results in ArcMap

(23 14--> Add one of the newly created feature classes to

the Table of Contents.

14--> To view the calculated values, right click on the

added layer in the Table of Contents and open
the Attribute Table.

note: The results calculated by iTree appear as
additional columns in the geodataset.

To see example of the results in ArcMap, open
the visualization pdfs in the Instructions folder.

= 3 Tutorial_iTreeEco.gdb
5 Buile_Enw
[%] Fullnventory_Tutorial

[%*]) Fullinventory_Tutorial_IndividualTreeEffects
(%7 Fullinventory_Tutorial_IndividualTreeOtherEffects
0] Fulllnventory _Tutorial_IndividualTreePollutionEffects

report_IndividualTreeEffects
report_IndividualTreeOtherEffects
report_IndividualTreePollutionEffects

Figure 4.2 Successful Results from Get data from iTree

Figure 4.2 Successful Results from Get data from iTree
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